Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Die gute alte Hardware! Audio Interfaces, Synthesizer, usw.

Moderatoren: Tim, Mods

Antworten
SandroSX
Grünschnabel
Beiträge: 4
Registriert: 30 Mär 2009 - 19:14

Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von SandroSX » 31 Mär 2009 - 14:18

Hallo Allerseits,

beim Durchstöbern diverser Beiträge zum Thema Mackie Control Universal vs. Logic las ich des Öfteren von Stabilität, keinen Problemen, upgrades usw. Das kann ich leider gar nicht bestätigen, da unter Logic Pro nicht nur das Programm abgestürzt ist (logic.crashed), sondern sich der ganze Mac verabschiedet hat. Konkret: ein halbdurchsichtiger Schatten läuft auf dem Bildschirm von oben nach unten und eine Infobox mit 4 verschiedenen Sprachen sagt mehr oder weniger aus: "nur noch Stecker ziehen". Es reagiert komplett nichts mehr! Nach dem Hochfahren kommt wiederum eine Infobox, dass der Mac ziemlich dolle abgestürtzt ist, aber das Betriebssystem bzw. die Hardware hat keinen Schaden genommen. Ist die MCU aus, läuft Logic stabil. Seit Anfang des Jahres bin ich auf Apple umgestiegen, vorher arbeitete ich mit der MCU auf Logic Emagic 5.5.1 unter Windows absturzfrei. Ich benutze nun nach dem Umstieg und aktuell Mac OS X 10.5.6, Logic Pro 8.0.2, Live 7.0.14, Native Instruments Audio Kontrol 1 (Driver 2.2.1.5).

Interessanterweise legte sich ein Freund den FaderFox für Ableton zu und berichtete, dass erst- und einmalig sein Mac (Macbook) mit den selben oben genannten Symptomen auf dem Monitor und nichts geht mehr, abstürtzte. Es ist natürlich unnötig zu erwähnen, dass das Ganze auch noch wirklich Live (!) geschah.

Nun meine Frage: kann mir da jemand vielleicht weiterhelfen bzw. hat einen Rat? Kann es sein, dass an irgendwelchen Schnittstellen, z. B. MIDI, Konflikte aufgrund von Bugs oder "Halbkompatibiltäten" bestehen? Hat Leopard bzw. ferner die aufgespielte Software doch Probleme mit externen Controllern? Es ist ja nicht so, dass ich mich von der MCU nicht trennen würde, zumal ich sie seit diesen Total-crashs eh nicht mehr verwende - nur kann es ja auch nicht sein, dass immer nur Neukauf die Lösung aller Probleme ist.

Für eure Hilfe oder Anregungen danke ich euch schon mal vorab.

Gruß

Sandro
Benutzeravatar
Christian Baum
Stamm User
Beiträge: 3076
Registriert: 20 Okt 2002 - 19:32
Logic Version: 9
Wohnort: Karlsruhe
Kontaktdaten:

Re: Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von Christian Baum » 31 Mär 2009 - 15:13

Tach,

was Du beschreibst, ist eine so genannte "Kernel Panic". Das ist mit das Übelste, was auf dem Mac passieren kann. Sowas hängt in den allermeisten Fällen mit Hardware oder fehlerhaften Treibern zusammen. Es muss aber nicht an der MCU und/oder Logic liegen, sondern könnte

- ein defektes Kabel
- ein defekter Hub oder Port
- ungünstiges Zusammenspiel mit anderen USB- oder sonstigen Geräten bzw. deren Treibern sein.

Wichtig zu wissen wäre erst mal, ob Du denn die neueste MCU Pro mit USB hast oder per MIDI in den Mac gehst.
USB-Kabel, Hubs und Ports können gerne mal kaputt sein. Auch können andere USB-Geräte sich mit der MCU kabbeln, sodass es zur KP kommt.
Wenn die MCU per MIDI am Mac hängt: An welchem MIDI Port denn? Eigenes MIDI-Interface oder ein im Audio-Interface integriertes? Für beide gilt: Sie können scheiße, oder die Treiber können veraltet, nicht Leo-fähig oder sonstwas sein.

Der Crash Report nach dem Neustart liefert ggf. Hinweise auf den Übeltäter. Poste den ganzen Sermon mal hier!

Sonstige Vorgehensweise:

- Alles abklemmen außer Maus, Tastatur, MCU.
- Falls es immer noch crasht: Kabel austauschen (alle, die in Verbindung mit der MCU verwendet werden), Port wechseln.
- Falls es dann immer noch crasht: Neueste MIDI-Interface-Treiber, falls relevant.
- Falls es dann immer noch crasht: Anderes MIDI-Interface oder anderen Hub verwenden oder MCU mal direkt per USB anhängen, falls MCU Pro.
- Falls es dann immer noch crasht: MCU mal an einem anderen Mac unter Logic probieren. Vielleicht hat Dein Mac andere Hardware-Probleme, die nur bei Zugriff auf die MCU zutage treten (RAM, Festplatte, irgendein mistiger Audio- oder sonstiger Treiber).

Das kann man beliebig ausdehnen und variieren. Im Prinzip kommst Du aber nicht um ausführlichste Ausschlusstests herum, denn eigentlich läuft die Kombination problemlos.

Gruß,

Christian
iMac i7 / 24 GB, Logic Pro X, RME Fireface 800, UAD-2 Satellite, Euphonix MC Mix, Adam P11A, Korg M3, Virus TI2 Polar, Zebra2, A.C.E., Kontakt 5

flickr / Twitter
SandroSX
Grünschnabel
Beiträge: 4
Registriert: 30 Mär 2009 - 19:14

Re: Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von SandroSX » 31 Mär 2009 - 16:12

Hallo Christian,

vielen Dank für die schnelle und schon mal sehr hilfreiche Antwort. Wie du selbst schreibst, werde ich um ausführliche Tests nicht herum kommen. Insofern würde ich mir am kommenden Wochenende mal die Zeit nehmen um die eine oder andere KP herbeizuführen (wohl ist mir bei dem Gedanken aber nicht, da das wie ein freiwilliger Besuch beim Urologen ausschaut 8O Ein entsprechendes Protokoll könnte ich dann aber posten. Dazu fällt mir noch ein, dass ein weiterer Controller: KORG Synthesizer (MS-20 v.1.2.2 der Legacy Collection) via USB an einem Hub angeschlossen ist, der dann wiederum ebenfalls im Mac endet. Allerdings ist der KORG offline.

Zu der Schaltung - ich habe die alte Universal, also das Vorgängermodell der jetzigen MCU Pro Version. Sie geht via MIDI in/out in das Audio Interface AK1 (vielleicht besteht der Konflikt auch wegen dem in/out?). Das Interface ist dann via USB an den Mac geschaltet. In Logic selbst ist das Audiointerface als Zentrale geroutet.

Ich würde das wie gesagt am kommenden WE mal testen. Auch wenn du bzgl. einer naheliegenden anderen Schaltung eine Vermutung hast, würde ich sie gerne ausprobieren. Aber vordergründig würde ich erstmal alle 'überflüssigen' Verbindungen wie Scanner, Drucker etc. inkl. des Hubs vom Mac trennen und schauen, warum was wie wann abstürzt.

Gruß

Sandro
Benutzeravatar
urban noise
Stamm User
Beiträge: 3628
Registriert: 04 Jun 2002 - 21:54
Logic Version: 0
Wohnort: hamburg
Kontaktdaten:

Re: Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von urban noise » 31 Mär 2009 - 16:27

Eine weitere Fehlerquelle könnte sein, wenn ein Midigerät in Logic auf den gleichen Midi-Port wie die MCU zugreift. Dies könnte ein Midiinstrument oder auch das Metronom sein. Ebenso solltest du in den Synchronisationseinstellungen von Logic schauen, daß auf den entsprechenden Midi-Port nicht zugegriffen wird.
SandroSX
Grünschnabel
Beiträge: 4
Registriert: 30 Mär 2009 - 19:14

Re: Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von SandroSX » 01 Apr 2009 - 10:26

Hallo Urban Noise,

vielen Dank für den Tipp. Werd das auch am WE mal überprüfen. Es wird dabei wohl nicht reichen, das MIDI-Gerät als Spur zu löschen, sondern muss als konkrete Einstellung vorgenommen werden? Denn so gesehen arbeite ich ausgehend von einem AUTOLOAD ohne die voreingestellten MIDI-Geräte mit einer leeren Oberfläche.
Benutzeravatar
urban noise
Stamm User
Beiträge: 3628
Registriert: 04 Jun 2002 - 21:54
Logic Version: 0
Wohnort: hamburg
Kontaktdaten:

Re: Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von urban noise » 01 Apr 2009 - 11:04

SandroSX hat geschrieben:Hallo Urban Noise,

vielen Dank für den Tipp. Werd das auch am WE mal überprüfen. Es wird dabei wohl nicht reichen, das MIDI-Gerät als Spur zu löschen, sondern muss als konkrete Einstellung vorgenommen werden? Denn so gesehen arbeite ich ausgehend von einem AUTOLOAD ohne die voreingestellten MIDI-Geräte mit einer leeren Oberfläche.
Spur löschen reicht nicht, dann müsste das Instrument im Environment Fenster gelöscht werden, was aber sinnfrei ist. Port für den Zugriff deaktivieren ist sinnvoller, es sei denn man ist sich sicher,in dem Projekt kein Midi Instrument mehr zu benötigen. Ansonsten erzeugt man halt ein neues.
SandroSX
Grünschnabel
Beiträge: 4
Registriert: 30 Mär 2009 - 19:14

Re: Logic Pro stürzt unter Mackie Control Universal v2.1.2 ab

Beitrag von SandroSX » 05 Apr 2009 - 17:04

Hallo Christian,

nun ist der Mac doch noch abgestürzt, nachdem ich gestern 8 (!) Stunden problemlos ohne irgendeinen Zwischenfall mit der MCU Logic bedient habe. Anbei das Crashprotokoll. Selbst mit viel Phantasie, könnte ich da keinen Verursacher herausinterpretieren.

Gruß

Sandro


Sun Apr 5 16:54:03 2009
panic(cpu 1 caller 0x001A9C68): Kernel trap at 0x00808d35, type 14=page fault, registers:
CR0: 0x8001003b, CR2: 0x00000000, CR3: 0x01090000, CR4: 0x00000660
EAX: 0x00000000, EBX: 0x0a637104, ECX: 0x00000000, EDX: 0x0a637000
CR2: 0x00000000, EBP: 0x77bfb928, ESI: 0x0a56dc00, EDI: 0x00000041
EFL: 0x00010202, EIP: 0x00808d35, CS: 0x00000008, DS: 0x0d510010
Error code: 0x00000000

Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
0x77bfb6b8 : 0x12b4f3 (0x45b13c 0x77bfb6ec 0x1335e4 0x0)
0x77bfb708 : 0x1a9c68 (0x464700 0x808d35 0xe 0x463eb0)
0x77bfb7e8 : 0x1a038d (0x77bfb800 0x40 0x77bfb928 0x808d35)
0x77bfb7f8 : 0x808d35 (0xe 0x48 0x77bf0010 0x420010)
0x77bfb928 : 0x808f2e (0xa637000 0xa637080 0x20 0x9e5bf9c)
0x77bfb958 : 0x43dbcb (0xa637000 0x77bfb9c0 0x1016324 0x8)
0x77bfb9f8 : 0x43f276 (0x810660 0xa637000 0xaa061a4 0x77bfbcd0)
0x77bfba58
Antworten